Jump to content


Posted Image


Photo

Cruise control Blinking (fast) Issue


  • Please log in to reply
14 replies to this topic

#1 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 16 April 2018 - 10:21 AM

Hi guys, hoping you can help.

 

15 plate 370z nismo

 

18K miles done. 

 

Recent work on the car: 

 

- 2 new tyres fitted on Thursday. 

- Washed the car on Saturday morning. Give the alloys/wheels a real good spray (brakes seemed ok when braking after) Started the car up and all of sudden had the cruise control blinking on the dash really fast. Turned the engine off and on, still blinking. Sunday drove the car and all was fine, no blinking, today seems fine as well. 

 

I've done some research and there is stuff online about when it blinks slowly, but this was pretty rapid blinking. It seems to have gone away now but a little concerned. 

 

Any idea what this could be? I have got a video of it if i can find how to upload. 

 

Thanks 



#2 LESmo

LESmo

    Founding Member

  • Committee Member (10)
  • 10,335 posts
Garage View Garage

Posted 16 April 2018 - 05:15 PM

Only thing I can find is either the Micro Switch on the Clutch - or losing communication with the ECU.  Is it still under warranty? - If it is  would book it in, there are several reports of it happening and stop happening and then happening again. 

 

I have never seen it.  Some reports seem to imply loss of communication with the ECU.  This seems to be repeated over the net (no telling its any help)

 

When the ECM detects any of the following conditions, the ECM will cancel the cruise operation and inform the driver by blinking indicator lamp.

Engine coolant temperature is slightly higher than the normal operating temperature, CRUISE lamp may blink slowly.

 

When the engine coolant temperature decreases to the normal operating temperature, CRUISE lamp will stop blinking and the cruise operation will be able to work by pressing SET/COAST switch or RESUME/ACCELERATE switch.

 

Malfunction for some self-diagnoses regarding ASCD control: SET lamp will blink quickly


Current  - 2014 (14) 370z NISMO in Storm White #229, JDM Carbon Nismo Kickplates, JDM Carbon Nismo B Pillars, Nismo Tyre Caps, Nismo Oil Cap, K&N Filters, MY15 Nismo Start Button.  GT-R Dome Lens Covers - LED Lights (Interior, trunk & numberplate) - Demand Engineering Full Valved Custom Exhaust SystemCustom Blank Button Delete
 
Previous - 2005 (55) 350z Azure GT Coupe, Parking Sensors, Z Tax Holder, Z Mats, Z Door Guards, White Reflectors, Z Tyre Caps, S2000 Aerial, BT Kit,
                                                                                                                                                                                                                                                                                    
sml_gallery_123_431_228285.png


#3 Paul_S

Paul_S

    Club Chairman and AutoGadgetZ Trader

  • Root Admin (10)
  • 33,248 posts
Garage View Garage

Posted 16 April 2018 - 07:08 PM

Sorry to ask a silly question, but it was definitely the cruise control light?

 

Was the car stationary when then light flashed, or was it when you were driving?


'A standard limited edition Yellow 370Zwith a plethora of minor bespoke mods' 

 

*one of 40 don't you know!

 
 


gallery_245_77_177171.png

 



I manufacture and sell 370Z & GT-R Reversing Camera (Backup Camera) Kits
 

WARNING - DO NOT TRUST NavTool WITH YOUR MONEY


#4 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 17 April 2018 - 08:21 AM

Sorry to ask a silly question, but it was definitely the cruise control light?

 

Was the car stationary when then light flashed, or was it when you were driving?

Both, was stationary when it started blinking after the car was cleaned. Then i turned engine on and off, drove 4 miles with it still flashing like mad. I'm 99% sure it was the cruise control light blinking. Green with a kind of dial on it. 



#5 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 17 April 2018 - 08:49 AM

Sorry to ask a silly question, but it was definitely the cruise control light?
 
Was the car stationary when then light flashed, or was it when you were driving?

Here's the video. 

 

https://youtu.be/trnaVLjFkpc


Edited by tom_nismo, 17 April 2018 - 09:15 AM.


#6 JohnFK

JohnFK

    ZedMeister

  • Moderators (10)
  • 10,756 posts
Garage View Garage

Posted 17 April 2018 - 09:08 AM

Let me start by saying I know nothing about 370Z's Cruise Control but something in my memory says that it also has a speed limiter setting? Could it be anything to do with that?


  • Gav C likes this
62/176 Ultra Yellow GT4 350Z - Muttley
(its the only Z in the village ....)
Champagne R35 GT-R MY15 Premium 45th Anniversary Edition - The Expensive Mistress
Vermilion Red R35 GT-R MY14 with Recaros - "The Car with No Name"
Blade Silver Juke NISMO Manual - Dumbo

Storm White Enhanced R35 GT-R
MY11 with Recaros - The General
Titanium R35 GT-R MY09 Premium Edition - Dastardly

 

#7 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 17 April 2018 - 09:15 AM

Let me start by saying I know nothing about 370Z's Cruise Control but something in my memory says that it also has a speed limiter setting? Could it be anything to do with that?

I somehow cant load the video in here after selecting bb code and media, and copy and pasting the link. But the direct link is above



#8 Kev T

Kev T

    Zedling

  • Members
  • PipPipPip
  • 1,031 posts
Garage View Garage

Posted 17 April 2018 - 02:29 PM

The problem is almost certainly to do with the CC microswitch under the  brake pedal either faulty or out of adjustment.



#9 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 17 April 2018 - 03:50 PM

The problem is almost certainly to do with the CC microswitch under the  brake pedal either faulty or out of adjustment.

Do you reckon its because i smashed the brakes with water whilst cleaning it? 

 

or nothing to do with it? 

 

thanks



#10 LESmo

LESmo

    Founding Member

  • Committee Member (10)
  • 10,335 posts
Garage View Garage

Posted 17 April 2018 - 05:24 PM

Let me start by saying I know nothing about 370Z's Cruise Control but something in my memory says that it also has a speed limiter setting? Could it be anything to do with that?

 

It does - it displays a slightly different symbol on the dash in Speed Limit (Green for one and I think orange for the other?).  I only use Speed Limiter so rarely use Cruise.

 

There are a few threads I read about the switch being a possible.  Lose connection to the switch is another.


Current  - 2014 (14) 370z NISMO in Storm White #229, JDM Carbon Nismo Kickplates, JDM Carbon Nismo B Pillars, Nismo Tyre Caps, Nismo Oil Cap, K&N Filters, MY15 Nismo Start Button.  GT-R Dome Lens Covers - LED Lights (Interior, trunk & numberplate) - Demand Engineering Full Valved Custom Exhaust SystemCustom Blank Button Delete
 
Previous - 2005 (55) 350z Azure GT Coupe, Parking Sensors, Z Tax Holder, Z Mats, Z Door Guards, White Reflectors, Z Tyre Caps, S2000 Aerial, BT Kit,
                                                                                                                                                                                                                                                                                    
sml_gallery_123_431_228285.png


#11 milanored

milanored

    Zedlet

  • Committee Member
  • PipPip
  • 361 posts

Posted 17 April 2018 - 05:27 PM

Do you reckon its because i smashed the brakes with water whilst cleaning it? 
 
or nothing to do with it? 
 
thanks

I would have thought they are designed to get wet don't see that to be it. If the light is blinking I go with a switch that is sticking open and shut as posted by others here as a good place to start

#12 Chubbs

Chubbs

    ZedMeister

  • Founding Member (10)
  • 16,164 posts
Garage View Garage

Posted 17 April 2018 - 07:31 PM

I somehow cant load the video in here after selecting bb code and media, and copy and pasting the link. But the direct link is above

 

I changed the 'https' to 'http', pasted it directly into this post and it works...

 

 

 

Edit - sorry, but I can't help with your cruise control issue!


gallery_22_517_7955.jpg

 

Most cars are A to B. Mine is A to Z.


#13 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 18 April 2018 - 08:06 AM

 

I changed the 'https' to 'http', pasted it directly into this post and it works...

 

 

 

Edit - sorry, but I can't help with your cruise control issue!

Its going into nissan soon. Still under warranty. 


  • Chubbs and LESmo like this

#14 Chubbs

Chubbs

    ZedMeister

  • Founding Member (10)
  • 16,164 posts
Garage View Garage

Posted 18 April 2018 - 11:20 AM

Good job you've got a video of it, just in case they 'can't replicate the issue, sir'. Where are you taking it?


gallery_22_517_7955.jpg

 

Most cars are A to B. Mine is A to Z.


#15 tom_nismo

tom_nismo

    Zedlister

  • User
  • Pip
  • 87 posts

Posted 19 April 2018 - 03:39 PM

Good job you've got a video of it, just in case they 'can't replicate the issue, sir'. Where are you taking it?

Telford Nissan 


  • LESmo likes this